summaryrefslogtreecommitdiff
path: root/web/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'web/Makefile.am')
-rw-r--r--web/Makefile.am17
1 files changed, 16 insertions, 1 deletions
diff --git a/web/Makefile.am b/web/Makefile.am
index 96e0530..58de96f 100644
--- a/web/Makefile.am
+++ b/web/Makefile.am
@@ -14,5 +14,20 @@ SUBDIRS = \
based_in = htdocs
include $(top_srcdir)/Makefile.common
-doc_DATA = index.php resources.html favicon.ico
+doc_DATA = index.php resources.html favicon.ico echolot/copied.stamp
#doc_DATA = account-create.php account-edit.php index.php login.php logout.php remsaint-subscription.php remsaint.php resources.html favicon.ico
+
+.PHONY: echolot/copied.stamp
+echolot/copied.stamp:
+ rsync -rav --exclude copied.stamp --delete $(ECHOLOT_BASE)/results/ echolot
+ touch "$@"
+
+clean:
+ rm -rf echolot
+
+install-data-local: echolot/copied.stamp
+ [ -d $(docdir) ] || mkdir $(docdir)
+ rsync -rav --delete echolot/ $(docdir)/echolot
+
+uninstall-local:
+ rm -f $(docdir)/echolot