summaryrefslogtreecommitdiff
path: root/web/Makefile.am
diff options
context:
space:
mode:
authorPeter Palfrader <peter@palfrader.org>2012-11-26 18:28:36 +0000
committerPeter Palfrader <peter@palfrader.org>2012-11-26 18:28:36 +0000
commit5af690bd8b920e4815ba51285d4e72e1ccd19330 (patch)
tree561db49fc10f9947230ab07388cb8a45f48c420e /web/Makefile.am
parent27ba00cb9222c674d545bfd98590386a2e063d70 (diff)
use date -R instead of 822-date
Diffstat (limited to 'web/Makefile.am')
-rw-r--r--web/Makefile.am17
1 files changed, 16 insertions, 1 deletions
diff --git a/web/Makefile.am b/web/Makefile.am
index 96e0530..58de96f 100644
--- a/web/Makefile.am
+++ b/web/Makefile.am
@@ -14,5 +14,20 @@ SUBDIRS = \
based_in = htdocs
include $(top_srcdir)/Makefile.common
-doc_DATA = index.php resources.html favicon.ico
+doc_DATA = index.php resources.html favicon.ico echolot/copied.stamp
#doc_DATA = account-create.php account-edit.php index.php login.php logout.php remsaint-subscription.php remsaint.php resources.html favicon.ico
+
+.PHONY: echolot/copied.stamp
+echolot/copied.stamp:
+ rsync -rav --exclude copied.stamp --delete $(ECHOLOT_BASE)/results/ echolot
+ touch "$@"
+
+clean:
+ rm -rf echolot
+
+install-data-local: echolot/copied.stamp
+ [ -d $(docdir) ] || mkdir $(docdir)
+ rsync -rav --delete echolot/ $(docdir)/echolot
+
+uninstall-local:
+ rm -f $(docdir)/echolot