summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorPeter Palfrader <peter@palfrader.org>2004-11-14 22:34:20 +0000
committerPeter Palfrader <peter@palfrader.org>2004-11-14 22:34:20 +0000
commitda03613b37f02bca8a3960b34a56f0d25470185a (patch)
treeb72fa26ff8e607b0b8e76a04bfb69f9a2d7e4aac /debian
parent716a492f46e41548947f7fd9b8a172279edc8426 (diff)
remove debconf stuff
Diffstat (limited to 'debian')
-rw-r--r--debian/README.Debian6
-rw-r--r--debian/changelog9
-rwxr-xr-xdebian/echolot.config98
-rwxr-xr-xdebian/echolot.postinst43
-rwxr-xr-xdebian/echolot.postinst.in119
-rw-r--r--debian/echolot.templates48
-rw-r--r--debian/po/POTFILES.in1
-rw-r--r--debian/po/fr.po126
-rw-r--r--debian/po/nl.po95
-rw-r--r--debian/po/templates.pot105
-rw-r--r--debian/remailers53
11 files changed, 57 insertions, 646 deletions
diff --git a/debian/README.Debian b/debian/README.Debian
index cfd25dd..eb3218e 100644
--- a/debian/README.Debian
+++ b/debian/README.Debian
@@ -19,4 +19,8 @@ Since many users installed Echolot without considering its implications the
default setup is now to no longer start the pingd in the default installation.
To actually enable it please modify /etc/default/echolot.
- -- Peter Palfrader <weasel@debian.org>, Tue, 12 Nov 2002 02:02:25 +0100
+If you want to run a pinger, please configure /etc/echolot/pingd.conf and
+/etc/default/echolot. Then start echolot using /etc/init.d/echolot start
+and add some addresses to it: /etc/default/echolot add remailer@example.com.
+
+ -- Peter Palfrader <weasel@debian.org>, Sun, 14 Nov 2004 23:31:24 +0100
diff --git a/debian/changelog b/debian/changelog
index 481f4da..7b1bc31 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+echolot (2.1.7-1) unstable; urgency=low
+
+ * New upstream version:
+ - remove debconf stuff.
+ - create echolot group in proper gid space.
+ - modify init script to allow 'enable' and 'disable' command.
+
+ -- Peter Palfrader <weasel@debian.org> Sun, 14 Nov 2004 23:33:41 +0100
+
echolot (2.1.6-2) unstable; urgency=low
* Add disable and enable to allowed commands in init script.
diff --git a/debian/echolot.config b/debian/echolot.config
deleted file mode 100755
index 16d5f76..0000000
--- a/debian/echolot.config
+++ /dev/null
@@ -1,98 +0,0 @@
-#!/usr/bin/perl -w
-
-use strict;
-
-use Debconf::Client::ConfModule;
-use English;
-
-my $address;
-my $operator;
-my $sitename;
-my $recipient_delimiter;
-
-if ( -e '/etc/echolot/pingd.conf' ) {
- my $CONFIG;
- {
- local $/ = undef;
- open(CONFIGCODE, '/etc/echolot/pingd.conf') or
- die ("Cannot open /etc/echolot/pingd.conf: $!");
- my $config_code = <CONFIGCODE>;
- close (CONFIGCODE);
- ($config_code) = $config_code =~ /^(.*)$/s;
- eval ($config_code);
- ($EVAL_ERROR) and
- die("Evaling config code from /etc/echolot/pingd.conf returned error: $EVAL_ERROR");
- }
-
- $address = $CONFIG->{'my_localpart'}.'@'.$CONFIG->{'my_domain'} if (defined $CONFIG->{'my_localpart'} && defined $CONFIG->{'my_domain'});
- $operator = $CONFIG->{'operator_address'} if (defined $CONFIG->{'operator_address'});
- $sitename = $CONFIG->{'sitename'} if (defined $CONFIG->{'sitename'});
- $recipient_delimiter = $CONFIG->{'recipient_delimiter'} if (defined $CONFIG->{'recipient_delimiter'});
-};
-
-my $mailname;
-$mailname = `cat /etc/mailname` if ( -e '/etc/mailname' );
-$mailname = `hostname` unless ( defined $mailname );
-$mailname = 'example.org' unless ( defined $mailname );
-chomp $mailname;
-
-$address = 'echolot@'.$mailname unless defined $address;
-$operator = 'abuse@'.$mailname unless defined $operator;
-$sitename = $mailname unless defined $sitename;
-$recipient_delimiter = '' unless defined $recipient_delimiter;
-
-Debconf::Client::ConfModule::set('echolot/address', $address);
-Debconf::Client::ConfModule::set('echolot/operator', $operator);
-Debconf::Client::ConfModule::set('echolot/sitename', $sitename);
-Debconf::Client::ConfModule::set('echolot/recipient_delimiter', $recipient_delimiter);
-
-
-my $state = 1;
-my $numerr = 0;
-
-Debconf::Client::ConfModule::version('2.0');
-Debconf::Client::ConfModule::capb('backup');
-while (1) {
- if ($state == 0) {
- $state = 1;
- } elsif ($state == 1) {
- Debconf::Client::ConfModule::input('high', 'echolot/address');
- my @return = Debconf::Client::ConfModule::go();
-
- $address = Debconf::Client::ConfModule::get('echolot/address');
- unless ($address =~ /@/) {
- $address .= '@'.$mailname;
- Debconf::Client::ConfModule::set('echolot/address', $address);
- $numerr++;
- next if ($numerr <= 5);
- };
-
- if ($return[0] == 30) {
- $numerr = 0;
- $state--;
- } else {
- $numerr = 0;
- $state++;
- };
- next;
- } elsif ($state == 2) {
- Debconf::Client::ConfModule::input('high', 'echolot/operator');
- Debconf::Client::ConfModule::input('high', 'echolot/sitename');
- Debconf::Client::ConfModule::input('high', 'echolot/recipient_delimiter');
- Debconf::Client::ConfModule::input('medium', 'echolot/addnow');
- } elsif ($state == 3) {
- last;
- } else {
- die ("Unknown state $state");
- };
-
- my @return = Debconf::Client::ConfModule::go();
- if ($return[0] == 30) {
- $state--;
- } else {
- $state++;
- };
-};
-
-# vim:set ts=4:
-# vim:set shiftwidth=4:
diff --git a/debian/echolot.postinst b/debian/echolot.postinst
new file mode 100755
index 0000000..59cd723
--- /dev/null
+++ b/debian/echolot.postinst
@@ -0,0 +1,43 @@
+#!/bin/sh -e
+
+# postinst for Echolot
+
+. /usr/share/debconf/confmodule
+
+# Make sure the echolot user exists
+adduser --quiet \
+ --quiet \
+ --system \
+ --disabled-password \
+ --shell /bin/bash \
+ --home /var/lib/echolot \
+ --no-create-home \
+ --group \
+ --gecos "Echolot Pinger" \
+ echolot
+
+# Give the echolot user write permissions to /var/log/echolot/echolot.log
+touch /var/log/echolot/echolot.log
+chown echolot.adm /var/log/echolot/echolot.log
+chmod 640 /var/log/echolot/echolot.log
+# and /var/lib/echolot
+if ( ! dpkg-statoverride --list /var/lib/echolot > /dev/null ); then
+ dpkg-statoverride --update --add root echolot 02775 /var/lib/echolot
+fi
+# and /var/run/echolot
+if ( ! dpkg-statoverride --list /var/run/echolot > /dev/null ); then
+ dpkg-statoverride --update --add root echolot 02770 /var/run/echolot
+fi
+
+# remove debconf stuff
+if [ "$1" = "configure" ] && [ -e /usr/share/debconf/confmodule ]; then
+ if dpkg --compare-versions "$2" lt "2.1.7" ; then
+ /usr/share/debconf/confmodule
+ db_purge
+ fi
+fi
+
+#DEBHELPER#
+
+# vim:set ts=4:
+# vim:set shiftwidth=4:
diff --git a/debian/echolot.postinst.in b/debian/echolot.postinst.in
deleted file mode 100755
index 1f68dc8..0000000
--- a/debian/echolot.postinst.in
+++ /dev/null
@@ -1,119 +0,0 @@
-#!/bin/sh -e
-
-# postinst for Echolot
-
-. /usr/share/debconf/confmodule
-
-# Make sure the echolot user exists
-adduser --quiet \
- --quiet \
- --system \
- --disabled-password \
- --shell /bin/bash \
- --home /var/lib/echolot \
- --no-create-home \
- --group \
- --gecos "Echolot Pinger" \
- echolot
-
-# Give the echolot user write permissions to /var/log/echolot/echolot.log
-touch /var/log/echolot/echolot.log
-chown echolot.adm /var/log/echolot/echolot.log
-chmod 640 /var/log/echolot/echolot.log
-# and /var/lib/echolot
-if ( ! dpkg-statoverride --list /var/lib/echolot > /dev/null ); then
- dpkg-statoverride --update --add root echolot 02775 /var/lib/echolot
-fi
-# and /var/run/echolot
-if ( ! dpkg-statoverride --list /var/run/echolot > /dev/null ); then
- dpkg-statoverride --update --add root echolot 02770 /var/run/echolot
-fi
-
-
-########################################################################
-# User configuration
-########################################################################
-if [ "$1" = "configure" ]; then
-
- ########################
- # Echolot configuration
-
- filename=`tempfile`;
-cat > $filename << 'EOF'
-#!/usr/bin/perl -w
-
- use strict;
- use Debconf::Client::ConfModule;
- use IO::File;
-
- my $postblock = "";
- my $preblock = "";
-
- if ( -e "/etc/echolot/pingd.conf" ) {
- my $fh = new IO::File;
- $fh->open("/etc/echolot/pingd.conf") or
- die ("Cannot open /etc/echolot/pingd.conf: $!");
- while (<$fh>) {
- last if (/^### BEGIN DEBCONF SECTION/);
- $preblock .= $_;
- };
- while (<$fh>) {
- last if (/^### END DEBCONF SECTION/);
- };
- while (<$fh>) {
- $postblock .= $_;
- };
- $fh->close() or
- die ("Cannot close /etc/echolot/pingd.conf: $!");
- };
-
- my $address = Debconf::Client::ConfModule::get("echolot/address");
- my $operator = Debconf::Client::ConfModule::get("echolot/operator");
- my $sitename = Debconf::Client::ConfModule::get("echolot/sitename");
- my $recipient_delimiter = Debconf::Client::ConfModule::get("echolot/recipient_delimiter");
-
- my ($local, $domain) = split (/@/, $address, 2);
-
- my $debconf = sprintf("\$CONFIG->{q{my_localpart} } = q{%s};\n", $local);
- $debconf .= sprintf("\$CONFIG->{q{my_domain} } = q{%s};\n", $domain);
- $debconf .= sprintf("\$CONFIG->{q{operator_address} } = q{%s};\n", $operator);
- $debconf .= sprintf("\$CONFIG->{q{sitename} } = q{%s};\n", $sitename);
- $debconf .= sprintf("\$CONFIG->{q{recipient_delimiter} } = q{%s};\n", $recipient_delimiter);
-
- my $fh = new IO::File;
- $fh->open(">/etc/echolot/pingd.conf") or
- die ("Cannot open /etc/echolot/pingd.conf: $!");
- print $fh $preblock .
- "### BEGIN DEBCONF SECTION\n" .
- $debconf .
- "1;\n" .
- "### END DEBCONF SECTION\n" .
- $postblock or
- die ("Cannot write to /etc/echolot/pingd.conf: $!");
- $fh->close or
- die ("Cannot close /etc/echolot/pingd.conf: $!");
-EOF
- chmod +x $filename;
- $filename
- rm $filename
-fi
-
-#DEBHELPER#
-
-########################################################################
-# Configuration reprise
-########################################################################
-if [ "$1" = "configure" ]; then
- db_get echolot/addnow || true
- if [ "$RET" = "true" ]; then
- /etc/init.d/echolot add REMAILER_LIST
- # But don't do it again unless the user asks for it
- db_set echolot/addnow false
- fi
-fi
-
-
-db_stop
-
-# vim:set ts=4:
-# vim:set shiftwidth=4:
diff --git a/debian/echolot.templates b/debian/echolot.templates
deleted file mode 100644
index 242af6b..0000000
--- a/debian/echolot.templates
+++ /dev/null
@@ -1,48 +0,0 @@
-Template: echolot/address
-Type: string
-_Description: E-mail address of your pinger
- Email to this address must reach your pinger somehow. Either it gets
- delivered to your box directly or you have fetchmail installed or some
- other way.
-
-Template: echolot/operator
-Type: string
-_Description: Operator address for your pinger
- Specify an address for the pinger operator.
-
-Template: echolot/sitename
-Type: string
-_Description: Site name
- Choose a name for your pinger site. This will be shown in all pages
- echolot produces.
-
-Template: echolot/addnow
-Type: boolean
-Default: true
-_Description: Add known remailers?
- This package has a built in list of some remailers. If you want they can
- be added to Echolot's database now. Otherwise you have to populate it by
- hand.
- .
- If you choose to add them Echolot will also fetch keys and configuration
- data immediatly.
-
-Template: echolot/recipient_delimiter
-Type: string
-_Description: Recipient delimiter
- Echolot strongly recommends using user defined mailboxes, i.e. mail sent
- to echolot+<somerandomstring>@yourdomain should reach echolot too.
- .
- In postfix this can be done by adding
- recipient_delimiter = +
- to your main.cf file.
- .
- The mailbox delimiter for exim4 can be specified by :
- local_part_suffix = -*
- local_part_suffix_optional
- in the router configuration (900_exim4-config_local_user in the debian
- package) if you want '-' to be your mailbox delimiter.
- .
- (If you know the procedure for other MTAs, please file a wishlist bug)
- .
- If you cannot or do not want to enable this please use an empty string.
diff --git a/debian/po/POTFILES.in b/debian/po/POTFILES.in
deleted file mode 100644
index 104092f..0000000
--- a/debian/po/POTFILES.in
+++ /dev/null
@@ -1 +0,0 @@
-[type: gettext/rfc822deb] echolot.templates
diff --git a/debian/po/fr.po b/debian/po/fr.po
deleted file mode 100644
index 346443a..0000000
--- a/debian/po/fr.po
+++ /dev/null
@@ -1,126 +0,0 @@
-#
-# Translators, if you are not familiar with the PO format, gettext
-# documentation is worth reading, especially sections dedicated to
-# this format, e.g. by running:
-# info -n '(gettext)PO Files'
-# info -n '(gettext)Header Entry'
-#
-# Some information specific to po-debconf are available at
-# /usr/share/doc/po-debconf/README-trans
-# or http://www.debian.org/intl/l10n/po-debconf/README-trans
-#
-# Developers do not need to manually edit POT or PO files.
-#
-msgid ""
-msgstr ""
-"Project-Id-Version: echolot (2.1-1)\n"
-"POT-Creation-Date: 2003-09-18 17:36+0200\n"
-"PO-Revision-Date: 2003-09-19 07:20+0100\n"
-"Last-Translator: Christian Perrier <bubulle@debian.org>\n"
-"Language-Team: French <debian-l10n-french@lists.debian.org>\n"
-"MIME-Version: 1.0\n"
-"Content-Type: text/plain; charset=iso-8859-15\n"
-"Content-Transfer-Encoding: 8bit\n"
-
-#. Description
-#: ../echolot.templates:3
-msgid "E-mail address of your pinger"
-msgstr "Adresse électronique de votre testeur"
-
-#. Description
-#: ../echolot.templates:3
-msgid ""
-"Email to this address must reach your pinger somehow. Either it gets "
-"delivered to your box directly or you have fetchmail installed or some other "
-"way."
-msgstr ""
-"Les courriels envoyés à cette adresse doivent atteindre votre testeur (« pinger ») "
-"d'une manière ou d'une autre. Cela peut se faire soit par distribution directe "
-"dans une boîte aux lettres, soit par l'intermédiaire de fetchmail ou d'une "
-"autre méthode."
-
-#. Description
-#: ../echolot.templates:10
-msgid "Operator address for your pinger"
-msgstr "Adresse électronique de l'opérateur de votre testeur"
-
-#. Description
-#: ../echolot.templates:10
-msgid "Specify an address for the pinger operator."
-msgstr ""
-"Veuillez indiquer l'adresse électronique de l'opérateur de votre testeur."
-
-#. Description
-#: ../echolot.templates:15
-msgid "Site name"
-msgstr "Nom de site"
-
-#. Description
-#: ../echolot.templates:15
-msgid ""
-"Choose a name for your pinger site. This will be shown in all pages echolot "
-"produces."
-msgstr ""
-"Veuillez choisir un nom pour votre site testeur. Ce nom sera affiché sur "
-"toutes les pages générées par echolot."
-
-#. Description
-#: ../echolot.templates:22
-msgid "Add known remailers?"
-msgstr "Faut-il ajouter des redirecteurs de courriel connus ?"
-
-#. Description
-#: ../echolot.templates:22
-msgid ""
-"This package has a built in list of some remailers. If you want they can be "
-"added to Echolot's database now. Otherwise you have to populate it by hand."
-msgstr ""
-"Ce paquet inclut une liste de redirecteurs de courriel (« remailers ») connus. Ils "
-"peuvent être ajoutés à la base de données d'Echolot maintenant, si vous le "
-"souhaitez. Dans le cas contraire, vous devrez renseigner cette liste vous-"
-"même."
-
-#. Description
-#: ../echolot.templates:22
-msgid ""
-"If you choose to add them Echolot will also fetch keys and configuration "
-"data immediatly."
-msgstr ""
-"Si vous choisissez de les ajouter, Echolot récupérera les clés et les "
-"données de configuration immédiatement."
-
-#. Description
-#: ../echolot.templates:32
-msgid "Recipient delimiter"
-msgstr "Délimiteur de destinataire (« recipient delimiter »)"
-
-#. Description
-#: ../echolot.templates:32
-msgid ""
-"Echolot strongly recommends using user defined mailboxes, i.e. mail sent to "
-"echolot+<somerandomstring>@yourdomain should reach echolot too."
-msgstr ""
-"Echolot recommande fortement l'utilisation de boîtes aux lettres "
-"personnalisables. En d'autres termes, les courriels envoyés à echolot"
-"+<chaînequelconque>@votredomaine doivent parvenir à echolot."
-
-#. Description
-#: ../echolot.templates:32
-msgid ""
-"In postfix this can be done by adding\n"
-" recipient_delimiter = +\n"
-"to your main.cf file. (If you know the procedure for other MTAs, please file "
-"a wishlist bug)"
-msgstr ""
-"Avec postfix, cela peut se faire en ajoutant\n"
-" recipient_delimiter = +\n"
-"au fichier main.cf (si vous connaissez la méthode appropriée pour les autres "
-"agents de distribution de courriel, veuillez envoyer un rapport de bogue de "
-"type « wishlist »)."
-
-#. Description
-#: ../echolot.templates:32
-msgid "If you cannot or do not want to enable this please use an empty string."
-msgstr ""
-"Si vous ne pouvez ou ne voulez pas activer cette fonctionnalité, veuillez ne "
-"rien indiquer ici."
diff --git a/debian/po/nl.po b/debian/po/nl.po
deleted file mode 100644
index a2f6a33..0000000
--- a/debian/po/nl.po
+++ /dev/null
@@ -1,95 +0,0 @@
-#
-# Translators, if you are not familiar with the PO format, gettext
-# documentation is worth reading, especially sections dedicated to
-# this format, e.g. by running:
-# info -n '(gettext)PO Files'
-# info -n '(gettext)Header Entry'
-#
-# Some information specific to po-debconf are available at
-# /usr/share/doc/po-debconf/README-trans
-# or http://www.debian.org/intl/l10n/po-debconf/README-trans
-#
-# Developers do not need to manually edit POT or PO files.
-#
-msgid ""
-msgstr ""
-"Project-Id-Version: echolot 2.1.3-1\n"
-"POT-Creation-Date: 2003-09-18 17:36+0200\n"
-"PO-Revision-Date: 2004-05-14 16:07+0100\n"
-"Last-Translator: Luk Claes <luk.claes@ugent.be>\n"
-"Language-Team: Debian l10n Dutch <debian-l10n-dutch@lists.debian.org>\n"
-"MIME-Version: 1.0\n"
-"Content-Type: text/plain; charset=iso-8859-1\n"
-"Content-Transfer-Encoding: 8bit\n"
-
-#. Description
-#: ../echolot.templates:3
-msgid "E-mail address of your pinger"
-msgstr "E-mailadres van uw Pinger"
-
-#. Description
-#: ../echolot.templates:3
-msgid "Email to this address must reach your pinger somehow. Either it gets delivered to your box directly or you have fetchmail installed or some other way."
-msgstr "E-mail naar dit adres moet uw Pinger op een of andere wijze bereiken. Het wordt rechtstreeks aan uw box afgeleverd, of u hebt fetchmail geïnstalleerd of een andere manier."
-
-#. Description
-#: ../echolot.templates:10
-msgid "Operator address for your pinger"
-msgstr "Operatoradres van uw Pinger"
-
-#. Description
-#: ../echolot.templates:10
-msgid "Specify an address for the pinger operator."
-msgstr "Geef een adres voor de Pinger-operator."
-
-#. Description
-#: ../echolot.templates:15
-msgid "Site name"
-msgstr "Sitenaam"
-
-#. Description
-#: ../echolot.templates:15
-msgid "Choose a name for your pinger site. This will be shown in all pages echolot produces."
-msgstr "Kies een naam voor uw Pinger-site. Deze zal in alle pagina's die echolot produceert, worden getoond."
-
-#. Description
-#: ../echolot.templates:22
-msgid "Add known remailers?"
-msgstr "Gekende remailers toevoegen?"
-
-#. Description
-#: ../echolot.templates:22
-msgid "This package has a built in list of some remailers. If you want they can be added to Echolot's database now. Otherwise you have to populate it by hand."
-msgstr "Dit pakket heeft een ingebouwde lijst van enkele remailers. Als u wilt, kunnen ze nu worden toegevoegd aan de Echolot-databank. Anders zult u handmatig moeten toevoegen."
-
-#. Description
-#: ../echolot.templates:22
-msgid "If you choose to add them Echolot will also fetch keys and configuration data immediatly."
-msgstr "Als u kiest om ze toe te voegen, dan zal Echolot ook onmiddellijk sleutels en configuratiedata ophalen."
-
-#. Description
-#: ../echolot.templates:32
-msgid "Recipient delimiter"
-msgstr "Scheiding tussen ontvangers"
-
-#. Description
-#: ../echolot.templates:32
-msgid "Echolot strongly recommends using user defined mailboxes, i.e. mail sent to echolot+<somerandomstring>@yourdomain should reach echolot too."
-msgstr "Echolot beveelt het gebruik van gebruikersgedefinieerde mailboxen sterk aan, bijvoorbeeld e-mail die verstuurd wordt naar echolot+<eenwillekeurigestring>@uwdomein moet ook echolot bereiken."
-
-#. Description
-#: ../echolot.templates:32
-msgid ""
-"In postfix this can be done by adding\n"
-" recipient_delimiter = +\n"
-"to your main.cf file. (If you know the procedure for other MTAs, please file a wishlist bug)"
-msgstr ""
-"In postfix kan dit worden gedaan door het volgende toe te voegen\n"
-" recipient_delimiter = +\n"
-"aan uw main.cf-bestand. (Als u de procedure voor andere MTA's kent, stuur dan een wishlist-bugrapport)"
-
-#. Description
-#: ../echolot.templates:32
-msgid "If you cannot or do not want to enable this please use an empty string."
-msgstr "Als u dit niet kunt of wilt aanschakelen, gebruik dan een lege string."
-
diff --git a/debian/po/templates.pot b/debian/po/templates.pot
deleted file mode 100644
index fdb7e73..0000000
--- a/debian/po/templates.pot
+++ /dev/null
@@ -1,105 +0,0 @@
-#
-# Translators, if you are not familiar with the PO format, gettext
-# documentation is worth reading, especially sections dedicated to
-# this format, e.g. by running:
-# info -n '(gettext)PO Files'
-# info -n '(gettext)Header Entry'
-#
-# Some information specific to po-debconf are available at
-# /usr/share/doc/po-debconf/README-trans
-# or http://www.debian.org/intl/l10n/po-debconf/README-trans
-#
-# Developers do not need to manually edit POT or PO files.
-#
-#, fuzzy
-msgid ""
-msgstr ""
-"Project-Id-Version: PACKAGE VERSION\n"
-"Report-Msgid-Bugs-To: \n"
-"POT-Creation-Date: 2003-09-18 17:36+0200\n"
-"PO-Revision-Date: YEAR-MO-DA HO:MI+ZONE\n"
-"Last-Translator: FULL NAME <EMAIL@ADDRESS>\n"
-"Language-Team: LANGUAGE <LL@li.org>\n"
-"MIME-Version: 1.0\n"
-"Content-Type: text/plain; charset=CHARSET\n"
-"Content-Transfer-Encoding: 8bit\n"
-
-#. Description
-#: ../echolot.templates:3
-msgid "E-mail address of your pinger"
-msgstr ""
-
-#. Description
-#: ../echolot.templates:3
-msgid ""
-"Email to this address must reach your pinger somehow. Either it gets "
-"delivered to your box directly or you have fetchmail installed or some other "
-"way."
-msgstr ""
-
-#. Description
-#: ../echolot.templates:10
-msgid "Operator address for your pinger"
-msgstr ""
-
-#. Description
-#: ../echolot.templates:10
-msgid "Specify an address for the pinger operator."
-msgstr ""
-
-#. Description
-#: ../echolot.templates:15
-msgid "Site name"
-msgstr ""
-
-#. Description
-#: ../echolot.templates:15
-msgid ""
-"Choose a name for your pinger site. This will be shown in all pages echolot "
-"produces."
-msgstr ""
-
-#. Description
-#: ../echolot.templates:22
-msgid "Add known remailers?"
-msgstr ""
-
-#. Description
-#: ../echolot.templates:22
-msgid ""
-"This package has a built in list of some remailers. If you want they can be "
-"added to Echolot's database now. Otherwise you have to populate it by hand."
-msgstr ""
-
-#. Description
-#: ../echolot.templates:22
-msgid ""
-"If you choose to add them Echolot will also fetch keys and configuration "
-"data immediatly."
-msgstr ""
-
-#. Description
-#: ../echolot.templates:32
-msgid "Recipient delimiter"
-msgstr ""
-
-#. Description
-#: ../echolot.templates:32
-msgid ""
-"Echolot strongly recommends using user defined mailboxes, i.e. mail sent to "
-"echolot+<somerandomstring>@yourdomain should reach echolot too."
-msgstr ""
-
-#. Description
-#: ../echolot.templates:32
-msgid ""
-"In postfix this can be done by adding\n"
-" recipient_delimiter = +\n"
-"to your main.cf file. (If you know the procedure for other MTAs, please file "
-"a wishlist bug)"
-msgstr ""
-
-#. Description
-#: ../echolot.templates:32
-msgid "If you cannot or do not want to enable this please use an empty string."
-msgstr ""
diff --git a/debian/remailers b/debian/remailers
deleted file mode 100644
index a3ec4b5..0000000
--- a/debian/remailers
+++ /dev/null
@@ -1,53 +0,0 @@
-0062@plank.0062.com
-remailer@aarg.net
-mixmaster@anon.978.org
-mixmaster@firenze.linux.it
-mixmaster@remailer.privacy.at
-remailer@bikikii.ath.cx
-birdseed@xevious.kicks-ass.net
-mixmaster@mixmaster.thebunker.net
-cheshire@cheshire.dyndns.org
-remailer@xenophon.homeip.net
-mix@outel.org
-cmeclax@ixazon.dynip.com
-remailer@gacracker.org
-anon@ecn.org
-cside@cside.dyndns.org
-mixmaster@cthulu.joatcrafts.org
-dingo1@dingoremailer.com
-remailer@dizum.com
-dot@remailer.hyperreal.info
-mix@dreamcast.kirknet.net
-remailer@freedom.gmsociety.org
-godot@remailer.frell.eu.org
-frogremailer@frogadmin.yi.org
-harmless@minder.net
-anon@remailer.hastio.org
-remailer@eocto.net
-holodeck@usenet-nomads.com
-italyremailer@iol.it
-remailer@mail.jmbcv.net
-mix@buckwheat.jwiz.org
-mix@anon.lcs.mit.edu
-mix@nox.lemuria.org
-remailer@libertynews.org
-narnia-remailer@gmx.net
-remailer@noisebox.remailer.org
-mixclient@notatla.demon.co.uk
-mix@arancio.net
-anon@paranoici.org
-mixer@immd1.informatik.uni-erlangen.de
-patriot@socialistsushi.com
-randseed@melontraffickers.com
-ratbait@frogger.kicks-ass.net
-anon@riot.eu.org
-rot26@mix.uucico.de
-scream2@tiscali.co.uk
-mixmaster@mix.gotdns.org
-mix@squirrel.owl.de
-mixmaster@tatooine.homelinux.net
-remailer@cypherpunks.to
-remail@cyberjunkiez.de
-mix@vger.smbtech.com
-remailer@weirdsilence.net
-remailer@xmailer.ods.org