summaryrefslogtreecommitdiff
path: root/web/tls/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'web/tls/Makefile.am')
-rw-r--r--web/tls/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/web/tls/Makefile.am b/web/tls/Makefile.am
new file mode 100644
index 0000000..72b21e1
--- /dev/null
+++ b/web/tls/Makefile.am
@@ -0,0 +1,35 @@
+SUBDIRS =
+
+based_in = htdocs
+include $(top_srcdir)/Makefile.common
+
+doc_DATA = index.html
+
+
+addresses: $(ECHOLOT_BASE)/results/mlist2.txt $(ECHOLOT_BASE)/results/rlist2.txt
+ cat $(ECHOLOT_BASE)/results/mlist2.txt $(ECHOLOT_BASE)/results/rlist2.txt > addresses
+
+tls-result: addresses
+ if [ -e $@ ] ; then \
+ mod=`stat -c '%Y' $@`; \
+ else \
+ mod=0; \
+ fi; \
+ now=`date +'%s'`; \
+ if [ $$(( $$now - $$mod )) -gt $(TLS_AGE) ]; then \
+ $(top_srcdir)/bin/tls-check < $< > $@; \
+ fi
+
+index.html: tls-result
+ rm -f cert-*.txt;
+ $(top_srcdir)/bin/tls2html < $< > $@;
+
+clean:
+ rm -f tls-result index.html addresses cert-*.txt addresses
+
+install-data-local: index.html
+ [ -d $(docdir) ] || mkdir $(docdir)
+ cp cert-*.txt $(docdir)
+
+uninstall-local: index.html
+ rm -f $(docdir)/cert-*.txt