summaryrefslogtreecommitdiff
path: root/web/latency/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'web/latency/Makefile.am')
-rw-r--r--web/latency/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/web/latency/Makefile.am b/web/latency/Makefile.am
new file mode 100644
index 0000000..e85adf5
--- /dev/null
+++ b/web/latency/Makefile.am
@@ -0,0 +1,33 @@
+SUBDIRS =
+
+based_in = htdocs
+include $(top_srcdir)/Makefile.common
+
+doc_DATA = result/stats.txt
+
+result/stats.txt: $(ECHOLOT_BASE)/results/thesaurus/index.txt $(ECHOLOT_BASE)/data $(ECHOLOT_BASE)/data/*
+ [ -d result ] || mkdir result
+ [ -d tmp ] || mkdir tmp
+ if [ -e $@ ] ; then \
+ mod=`stat -c '%Y' $@`; \
+ else \
+ mod=0; \
+ fi; \
+ now=`date +'%s'`; \
+ if [ $$(( $$now - $$mod )) -gt $(LATENCY_AGE) ]; then \
+ $(top_srcdir)/bin/latency-graphs $(ECHOLOT_BASE); \
+ else \
+ echo "** Skipping Latency build"; \
+ fi
+
+clean:
+ rm -rf result tmp
+
+install-data-local: result/stats.txt
+ [ -d $(docdir) ] || mkdir $(docdir)
+ cp result/*.png $(docdir)
+ cp result/*.html $(docdir)
+
+uninstall-local:
+ rm -f $(docdir)/*.png
+ rm -f $(docdir)/*.html