summaryrefslogtreecommitdiff
path: root/web/allpingers/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'web/allpingers/Makefile.am')
-rw-r--r--web/allpingers/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/web/allpingers/Makefile.am b/web/allpingers/Makefile.am
new file mode 100644
index 0000000..d76f5e4
--- /dev/null
+++ b/web/allpingers/Makefile.am
@@ -0,0 +1,42 @@
+SUBDIRS =
+
+based_in = htdocs
+include $(top_srcdir)/Makefile.common
+
+doc_DATA = allpingers.txt allpingers.xml index.html
+
+
+
+index.html: index.wml allpingers.txt
+ wml -n -o $@ $<
+
+#SRCS = $(wildcard pingers/*)
+#all: allpingers.txt allpingers.xml $(HTMLFILES)
+
+SRCS = pingers/*
+allpingers.txt: $(SRCS) pingers/
+ ( \
+ echo "# A L L P I N G E R S' I N D E X"; \
+ echo "#"; \
+ echo -n "# Generated: "; \
+ date --rfc-822; \
+ echo "#"; \
+ echo "# This list can be found on the web on http://www.noreply.org/"; \
+ echo "#"; \
+ echo "# If anything is wrong/broken/missing please mail the maintainer at"; \
+ echo "# pingers@palfrader.org"; \
+ echo; \
+ for i in `cd pingers && ls -1`; do \
+ if (echo -n "$$i" | grep -vq '[^a-z0-9]') ; then \
+ echo "[$$i]"; \
+ cat pingers/$$i; \
+ echo ; \
+ fi; \
+ done \
+ ) > $@
+
+allpingers.xml: allpingers.txt
+ $(top_srcdir)/bin/allpingers-ini2xml < $< > $@
+
+clean:
+ rm -f $(doc_DATA)