summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorPeter Palfrader <peter@palfrader.org>2012-10-15 14:18:52 +0000
committerPeter Palfrader <peter@palfrader.org>2012-10-15 14:18:52 +0000
commitf34a0629afdb5445f9881d963a7e5fd3686d5c06 (patch)
treeee0e403488675235dd63b8d44c0f8d9d8133aaac /debian
parentb5b8411b6039d621842c93d7fb1175cd0a786481 (diff)
No longer ship /var/run/echolot in the package (closes: #689889)
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog4
-rw-r--r--debian/echolot.dirs1
-rwxr-xr-xdebian/echolot.init8
-rwxr-xr-xdebian/echolot.postinst9
-rwxr-xr-xdebian/echolot.postrm1
5 files changed, 16 insertions, 7 deletions
diff --git a/debian/changelog b/debian/changelog
index ee6ca90..c5c20a2 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,8 +3,10 @@ echolot (2.1.8-X) XXstable; urgency=low
* Fix a typo in the pingd manpage.
* Fix an error in README.Debian where we say /etc/default/echolot
when we mean /etc/init.d/echolot.
+ * No longer ship /var/run/echolot in the package. Based upon
+ work by Thomas Goirand (closes: #689889).
- -- Peter Palfrader <weasel@debian.org> Sun, 25 May 2008 19:22:29 +0200
+ -- Peter Palfrader <weasel@debian.org> Mon, 15 Oct 2012 16:16:04 +0200
echolot (2.1.8-6) unstable; urgency=low
diff --git a/debian/echolot.dirs b/debian/echolot.dirs
index 05c67a0..df00cbf 100644
--- a/debian/echolot.dirs
+++ b/debian/echolot.dirs
@@ -1,7 +1,6 @@
usr/bin
usr/share/perl5
var/lib/echolot
-var/run/echolot
var/log/echolot
etc/echolot
etc/default
diff --git a/debian/echolot.init b/debian/echolot.init
index 0ff2897..3247e18 100755
--- a/debian/echolot.init
+++ b/debian/echolot.init
@@ -25,7 +25,8 @@ VERBOSE=0
# You probably don't want to mess with stuff below this line
################################################################
-PIDFILE=/var/run/echolot/pingd.pid
+RUNDIR=/var/run/echolot
+PIDFILE="$RUNDIR/pingd.pid"
CHECKULIMIT=1
CHECKUID=1
USER=echolot
@@ -41,6 +42,11 @@ export PATH
# Reads config file (will override defaults above)
[ -r /etc/default/echolot ] && . /etc/default/echolot
+if [ ! -d ${RUNDIR} ]; then
+ mkdir "$RUNDIR"
+ chown root:"$GROUP" "$RUNDIR"
+ chmod 02770 "$RUNDIR"
+fi
wait_for_deaddaemon () {
PID=$1
diff --git a/debian/echolot.postinst b/debian/echolot.postinst
index 4004475..3abf03d 100755
--- a/debian/echolot.postinst
+++ b/debian/echolot.postinst
@@ -9,6 +9,11 @@ if [ "$1" = "configure" ] && [ -e /usr/share/debconf/confmodule ]; then
db_stop
fi
fi
+if [ "$1" = "configure" ] && dpkg --compare-versions "$2" lt "2.1.8-7"; then
+ if ( dpkg-statoverride --list /var/run/echolot > /dev/null ); then
+ dpkg-statoverride --remove /var/run/echolot
+ fi
+fi
# Make sure the echolot user exists
adduser --quiet \
@@ -30,10 +35,6 @@ chmod 640 /var/log/echolot/echolot.log
if ( ! dpkg-statoverride --list /var/lib/echolot > /dev/null ); then
dpkg-statoverride --update --add root echolot 02775 /var/lib/echolot
fi
-# and /var/run/echolot
-if ( ! dpkg-statoverride --list /var/run/echolot > /dev/null ); then
- dpkg-statoverride --update --add root echolot 02770 /var/run/echolot
-fi
#DEBHELPER#
diff --git a/debian/echolot.postrm b/debian/echolot.postrm
index a1627c2..f39acb8 100755
--- a/debian/echolot.postrm
+++ b/debian/echolot.postrm
@@ -6,6 +6,7 @@ case "$1" in
purge)
rm -rf /var/lib/echolot
rm -rf /var/log/echolot
+ rm -rf /var/run/echolot
rmdir /etc/echolot/templates 2>/dev/null || true
rmdir /etc/echolot 2>/dev/null || true
dpkg-statoverride --remove /var/run/echolot >/dev/null 2>&1 || true