summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorPeter Palfrader <peter@palfrader.org>2006-03-06 14:44:58 +0000
committerPeter Palfrader <peter@palfrader.org>2006-03-06 14:44:58 +0000
commite7213fc062586bbcf8e2e104a3a6a668617be477 (patch)
tree3ac9133df81d628694ce1447012b4564dbfb9810 /debian
parent7fbf202942d076189c89ba457a891951bf7fe58e (diff)
Properly quote arguments to su -c, since its behaviour has changed.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rwxr-xr-xdebian/echolot.init6
2 files changed, 8 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 3600e7d..476af94 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+echolot (2.1.8-4) unstable; urgency=low
+
+ * Properly quote arguments to su -c, since its behaviour has changed.
+
+ -- Peter Palfrader <weasel@debian.org> Mon, 6 Mar 2006 15:43:09 +0100
+
echolot (2.1.8-3) unstable; urgency=low
* Increase Standards-Version to 3.6.2 from 3.6.1.
diff --git a/debian/echolot.init b/debian/echolot.init
index fc14c63..6d4d121 100755
--- a/debian/echolot.init
+++ b/debian/echolot.init
@@ -139,14 +139,13 @@ reload|force-reload|restart)
;;
process|add|delete|set|setremailercaps|deleteremailercaps|getkeyconf|sendpings|sendchainpings|buildstats|buildkeys|buildthesaurus|buildfromlines|dumpconf|summary|enable|disable)
# Check for right User
- SU=""
if [ "$CHECKUID" -gt "0" ]; then
CUID=`id -u`
CUIDNAME=`id -nu`
if [ "$CUIDNAME" = "$USER" ]; then
- SU=""
+ $DAEMON "$@"
elif [ "$CUID" = "0" ]; then
- SU="su $USER -c"
+ su $USER -c "$DAEMON $@"
else
echo "You are neither $USER nor root. Aborting." >&2
exit 1;
@@ -154,7 +153,6 @@ process|add|delete|set|setremailercaps|deleteremailercaps|getkeyconf|sendpings|s
fi
echo "Running $DESC: $NAME $1..."
- $SU $DAEMON "$@"
echo "done."
;;
*)