summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorPeter Palfrader <peter@palfrader.org>2002-11-12 01:07:05 +0000
committerPeter Palfrader <peter@palfrader.org>2002-11-12 01:07:05 +0000
commita5a75de615b8e131c4be7f3f12c2b293fa997ae3 (patch)
tree2f563fce83ce5867ceb754da6028ac768f4e2249 /debian
parent99759fe3d2276a250881acbe5390ca00409dd346 (diff)
Have Echolot disabled by default in /etc/default/echolot.
Add some more comments to README.Debian. Also process pending commands upon pingd startup.
Diffstat (limited to 'debian')
-rw-r--r--debian/README.Debian24
-rw-r--r--debian/changelog5
-rw-r--r--debian/echolot.default12
-rw-r--r--debian/echolot.dirs1
-rwxr-xr-xdebian/echolot.init24
-rwxr-xr-xdebian/rules1
6 files changed, 46 insertions, 21 deletions
diff --git a/debian/README.Debian b/debian/README.Debian
index dc7189d..cfd25dd 100644
--- a/debian/README.Debian
+++ b/debian/README.Debian
@@ -2,21 +2,21 @@ Echolot for Debian
------------------
Make sure mail to the Echolot pinger reaches /var/mail/echolot (or configure
-echolot to read it from any other location).
-
-
-Make sure your MTA supports user defined mailboxes. so that
-my_localpart+anything@my_domain also reaches Echolot.
- ^^^^^^^^^
-If you use another character instead of + to indicate a user defined
-extension set recipient_delimiter accordingly in echolot.conf.
-
-postfix: add »recipient_delimiter = +« to main.cf.
-
+echolot to read it from any other location). Please really check that mail to
+the configured domain works. Any bounces will annoy dozends of remailer
+operators.
To send commands to pingd it's best to use the /etc/init.d/echolot script.
It takes care that pingd is only called as the correct user. See pingd(1) for a
list of commands and their description.
+If you run this pinger please consider publishing the results so that other
+people benefit from it. Announcing the URL to the remailer operators' list
+<remops@freedom.gmsociety.org>, the alt.privacy.anon-server Usenet newsgroup
+and sending a mail to pingers@palfrader.org would be apprechiated.
+
+Since many users installed Echolot without considering its implications the
+default setup is now to no longer start the pingd in the default installation.
+To actually enable it please modify /etc/default/echolot.
- -- Peter Palfrader <weasel@debian.org>, Sun, 11 Aug 2002 16:21:18 +0200
+ -- Peter Palfrader <weasel@debian.org>, Tue, 12 Nov 2002 02:02:25 +0100
diff --git a/debian/changelog b/debian/changelog
index fad961d..4ccc665 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,11 @@
echolot (2.0.5-2) unstable; urgency=low
* Add sendpings command to init script.
+ * Have Echolot disabled by default in /etc/default/echolot.
+ * Add some more comments to README.Debian.
+ * Also process pending commands upon pingd startup.
- -- Peter Palfrader <weasel@debian.org> Mon, 11 Nov 2002 03:23:21 +0100
+ -- Peter Palfrader <weasel@debian.org> Tue, 12 Nov 2002 02:06:17 +0100
echolot (2.0.5-1) unstable; urgency=low
diff --git a/debian/echolot.default b/debian/echolot.default
new file mode 100644
index 0000000..c0c1bc4
--- /dev/null
+++ b/debian/echolot.default
@@ -0,0 +1,12 @@
+# Defaults for echolot initscript
+# sourced by /etc/init.d/echolot
+# installed at /etc/default/echolot
+
+#
+# This is a POSIX shell fragment
+#
+
+VERBOSE=0
+
+# Only enable this after you've read /usr/share/doc/echolot/README.Debian
+RUN_ECHOLOT=0
diff --git a/debian/echolot.dirs b/debian/echolot.dirs
index 5bfa096..05c67a0 100644
--- a/debian/echolot.dirs
+++ b/debian/echolot.dirs
@@ -4,3 +4,4 @@ var/lib/echolot
var/run/echolot
var/log/echolot
etc/echolot
+etc/default
diff --git a/debian/echolot.init b/debian/echolot.init
index 3ee6d0b..5276149 100755
--- a/debian/echolot.init
+++ b/debian/echolot.init
@@ -20,6 +20,10 @@ DESC="Echolot Ping Daemon"
NAME="pingd"
test -f $DAEMON || exit 0
+# Reads config file (will override defaults above)
+[ -r /etc/default/echolot ] && . /etc/default/echolot
+
+
wait_for_deaddaemon () {
PID=$1
sleep 3
@@ -97,14 +101,18 @@ start)
echo "$PIDFILE."
fi
fi
- echo -n "Starting $DESC: "
- start-stop-daemon \
- --start \
- --quiet \
- --pidfile $PIDFILE \
- --chuid $USER:$GROUP \
- --exec $DAEMON -- --detach $VERBOSE --quiet start
- echo "$NAME."
+ if [ $RUN_ECHOLOT -gt 0 ]; then
+ echo -n "Starting $DESC: "
+ start-stop-daemon \
+ --start \
+ --quiet \
+ --pidfile $PIDFILE \
+ --chuid $USER:$GROUP \
+ --exec $DAEMON -- --detach $VERBOSE --process --quiet start
+ echo "$NAME."
+ else
+ echo "Not starting $DESC: disabled in configuration"
+ fi
;;
stop)
diff --git a/debian/rules b/debian/rules
index 1aedc2f..e88d42b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -43,6 +43,7 @@ install: build
tar c --exclude CVS --exclude .cvsignore templates | tar xv -C $(CURDIR)/debian/echolot/etc/echolot
install -m 755 pingd $(CURDIR)/debian/echolot/usr/bin/
install -m 644 debian/pingd.conf $(CURDIR)/debian/echolot/etc/echolot
+ install -m 644 debian/echolot.default $(CURDIR)/debian/echolot/etc/default/echolot
binary-indep: build install