summaryrefslogtreecommitdiff
path: root/web/meta/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'web/meta/Makefile.am')
-rw-r--r--web/meta/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/web/meta/Makefile.am b/web/meta/Makefile.am
new file mode 100644
index 0000000..4c82ce1
--- /dev/null
+++ b/web/meta/Makefile.am
@@ -0,0 +1,40 @@
+SUBDIRS =
+
+based_in = htdocs
+include $(top_srcdir)/Makefile.common
+
+doc_DATA = index.html meta.1.html meta.2.html
+
+stamp-cache: ../allpingers/allpingers.txt
+ if [ -e $@ ] ; then \
+ mod=`stat -c '%Y' $@`; \
+ else \
+ mod=0; \
+ fi; \
+ now=`date +'%s'`; \
+ if [ $$(( $$now - $$mod )) -gt $(PINGER_CACHE_AGE) ]; then \
+ $(top_srcdir)/bin/update-pinger-cache $< .; \
+ else \
+ echo "** Skipping Cache Update"; \
+ fi
+
+meta.1.html: stamp-cache
+ cp -a $< $@
+
+meta.2.html: stamp-cache
+ cp -a $< $@
+
+clean:
+ rm -f cache.*.txt error.*.txt meta.1.html meta.2.html
+
+install-data-local: stamp-cache
+ [ -d $(docdir) ] || mkdir $(docdir)
+ cp -a cache.*.txt error.*.txt $(docdir)
+ ! [ -f .htaccess ] || cp -a .htaccess $(docdir)
+
+uninstall-local:
+ rm -f $(docdir)/cache.*.txt
+ rm -f $(docdir)/error.*.txt
+ rm -f $(docdir)/.htaccess
+
+.PHONY: stamp-cache